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What is MaZda

1. MaZda is a tool for computation of textural image features in 2D 
and 3D images

2. It requires:
1. Microsoft Windows system (98, 2K, XP)

2. Fast processor 
(some implemented methods are time demanding)

3. Lots of memory 
(the bigger the image analyzed the bigger memory is needed)

3. Name MaZda is an acronym of „Macierz Zdarzeń”, which in 
Polish means Co-occurence matrix



  

Setting up MaZda

1. Insert the „MaZda 4.5 & Tutorials” CD into CD 
drive of you computer

2. Copy the „MaZda” folder into the hard drive of 
your computer 
(e.g. onto the C: hard drive)

3. Start MaZda by double-clicking on its icon or 
a filename (The MaZda.exe file is within a MaZda folder)

4. When first started MaZda will register file 
formats it uses on the system, so they will be 
assigned an „MZ” icon
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Loading image
There are several ways to load image 

into the MaZda program:
1. Open Explorer and double-click on the image 

file icon which is associated with MaZda. It 
will automatically start MaZda program and 
load the selected image.

2. Start MaZda, select File→Load image… or 
click Load image button, then select a file to 
be loaded with a Load image dialog window. 

3. Drag-and-drop image file from Windows 
Explorer into the MaZda window 

By default the image after being loaded will be colored 

with red. Colors are used to indicate regions of interest, 

which will be covered later during this presentation  
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Loading RAW images
MaZda is capable of loading images without headers or formatting 
information, called raw images. In case of loading raw image the 
user must provide additional information to correctly present the 
image. To set raw image formatting parameters, select File→Raw 
options… from the menu and use the Raw options dialog box. 

Hint: if the image formatting is unknown, check Auto reload 
and observe image while adjusting image parameters
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Viewing image

• To zoom image use 
zoom-in/zoom-out buttons or 
select View→Zoom option from 
the menu

• To set image grey-scale window 
or to adjust brightness and 
contrast, use Min/Max sliders. 

• To view thresholded image or to 
switch the image view off,
use the radio buttons located 
below the sliders.

Remark: Adjusting the image view options 

described here will not affect the image

analysis procedure. 
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Viewing image information

To view information 

on the loaded image 

select 

View→Image info…

from the menu
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Regions of interest
MaZda computes numerical values (textural features), which characterize an 
image or an image fragment (region of interest or ROI). To compute features 
within a ROI the shape of such ROI must be defined. 

Since MaZda works with grey-scale images, the ROI is indicated with a color 
superimposed on the grey-scale image. Up to 16 ROI shapes may be defined 
with use of 16 unique colors. These shapes may overlap if needed.

Example of an image 
presenting 11 separate 
objects, each object 
marked with unique color, 
which indicate they are 
separate ROIs
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ROI editing tools

ROI color selection bar. Right-clicking 
on the color button lets to assign a 
class name for a ROI

Created ROI indicator bar. Buttons may be 
used for switching ROI on and off for viewing

ROI drawing mode buttons:
- non-overlapping regions
- overlapping regions
- erasing selected region
- erasing all the regions 

Morphology transformation tools

Drawing tools:
- draw line (right-click for width changing)
- fill-in
- draw elypsis or circle (while Ctrl pressed)
- draw rectangle or square (Ctrl)
- draw polygon

Move or copy the selected ROI
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Image histogram

To view an image 
histogram within 
region of interest 
select 
View→Histogram 

from the menu.
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ROI analysis options
To set the analysis options select 
Analysis→Options… from the MaZda menu.

For details on the methods implemented for 
textural analysis refer to the MaZda manual

(Help→Contents)
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Image analysis

To start the analysis select 
Analysis→Run from the MaZda 
menu.

The results are presented 

in a Report window:
  Tab-page per analysis
  Column per ROI
  Row per feature 
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Classes of ROIs

To assign a class name to a column, a feature vector computed for a 
particular ROI, click on the column header. Then, use a Class Name 
dialog box to set appropriate class name. 



 15

Saving data
Images, region of interest, option sets or reports 
may be saved to a disk files or loaded from disk 
files. Save your work before it’s too late!
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Exercise 1
• Start MaZda 
• Load image elgrain.bmp from Tutorials\2_Image_Analysis folder
• What is a height and width of the image in pixels?
• Define regions of interest, one per individual object.

– For capacitors use Draw polygon tool

– For grains set image view to three grey levels (thresholded), 
adjust thresholds to distinguish grain areas, and use Fill tool

• Set analysis options (Normalisation: +/- 3 Sigma, 6 bit COM analysis, Calculate 
wavelets energy, AR Model, and set other parameters of your choice) 

• Run the analysis
• Set up appropriate class names in a report window
• Observe the S(1,0)Contrast feature has higher values for Capacitors then for 

grains, and the Teta1 has higher values for grains.
• Find some other features that may be useful for discrimination of the two classes
• In the Report window select Feature selection→Fisher from the menu. It will start 

a procedure searching for the most discriminative features. Do the selected 
features discriminate the two classes?
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Exercise 2
• Start MaZda or, if it is already started, close all the report tab-pages
• Load image texture1.bmp from Tutorials\2_Image_Analysis folder
• Switch to the overlapping mode and create 16 regions of interest of an 

approximate size 60x60 pixels (observe the status bar for a size information) 
with Draw rectangle tool

• Set analysis options and run the analysis
• In a Report window set class name Biology for all the columns
• Load image texture2.bmp from Tutorials\2_Image_Analysis folder
• Run the analysis (use the same regions and analysis options as previously)
• In a Report window set class name Mineral for all the columns of the second 

tab-page
• Find features that may be useful for discrimination of the two classes
• In the Report window select Feature selection→Mutual information from the 

menu. It will start a procedure searching for the most discriminative features. Do 
the selected features discriminate the two classes?
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Color images
Procedures for texture analysis implemented in MaZda operate on grey-scale 
images only. The color image having three color components (red, green and 
blue), when loaded into MaZda, must be converted into the gray-scale image. 
Grey-scale images, which are results of such conversions are usually called color 
components or color channels. MaZda provides eight ways of such conversion, 
which may be selected through the File→Color conversion… menu option and a 
File→Color conversion dialog box. 
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Loading color image
Select File→Color conversion… menu option, with a Color conversion dialog box 
set the color to grey-scale conversion required, and press OK. Then, load color 
bitmap image into the MaZda software. 
To load another channel of the image that was already loaded select File→Color 
conversion… menu option, set the conversion required and press Reload 

Test image and results 
of color to gray-scale conversions

Natural image and its 
brightness, U and V channel
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Analysis
The analysis is run the same way 
as for grey-scale images. The 
resulting features are presented 
within a Report window. 

Depending on a color channel that 
was analyzed, corresponding 
prefix is added to every feature 
name. The exception is a 
brightness channel, for which no 
prefix is added.
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Combining analysis results
The analysis results computed for 
various channels of the same color 
image may be merged in a single 
tab-page.

To merge data from the currently 
viewed tab-page with data from the 
left-adjacent tab-page select 
File→Aggregate reports from the 
Report menu.   

Example of report that combines 
analysis results from three color 

channels of the same image
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Make it quick
To simplify the analysis of color images a plugin Color analysis has 
been written for MaZda. The plugin will automatically load consecutive 
color channels of the image, run the analysis and merge reports.

To quickly analyze all the channels 

of color image:

• Load a color image to be analyzed 

• Draw regions of interest

• Set analysis options

• Start the Color analysis plugin (Tools→Color analysis)
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Exercise 1
1. Start MaZda or, if it is already started, close all the report tab-pages 

2. Load brightness channel of dtex.bmp from Tutorials\3_Color_Analysis folder
(The image contains two similar textures)

3. Define 16 regions of interest of an approximate size 60x60 pixels, 8 regions per 
texture

4. Set analysis options and run the analysis (Analysis→Run)

5. Select the most discriminative features with a Fisher coefficient procedure 
(Observe values of Fisher coefficient computed for the selected features).

6. Start B11 (Tools→B11 analysis in the Report window)

7. Observe the raw data distribution (Analysis→Raw data in B11)

8. Close the report tab-page in the Report window of MaZda and start Color 
analysis plugin (Tools→Color analysis)

9. Repeat steps 5 – 7

10. In which case the Fisher coefficients where higher?

11. Which color channel holds the most valuable information for discrimination of the 
two textures?
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Exercise 2
1. Start MaZda or, if it is already started, close all the report tab-pages

2. There are three classes of endoscopic images in Tutorials\3_Color_Analysis 
folder, six images per class (file names beginning with letter A, B or C)

3. Load these images one by one, and perform Color analysis within the circular 
region of interest covering a field of view

4. Assign corresponding class names to the feature vectors produced by MaZda

5. Select the most discriminative features with a selection method of your choice

6. View the data distribution with B11

7. Which color channel holds the most valuable information for discrimination of 
the three classes?



MaZda 4.5 Tutorials 
3D Image Analysis

June 2006

Piotr M. Szczypiński



27

3D data analysis in MaZda

MaZda software is capable of 3D data analysis. It loads 3D data form:

•   image file series, where each file stores single cross-section of 3D volume 
•   a single file that stores complete 3D information

The 3D Editor of MaZda lets the user define three-dimensional regions of 
interest (ROI). The 3D Editor provides tools for:

•   placing volumes of predefined shape within 3D space of image data,
•   resizing them, 
•   stretching along selected direction and
•   rotating
•   segmentation of 3D image with an elastic surface model. 

MaZda computes a number of textural features within selected 3D regions of 
interest. The resulting feature lists (or feature vectors) are presented within the 
Report window. 
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Switching to the 3D analysis mode
After MaZda is started it usually shows a window for 2D-image manipulation. To 
switch to 3D image mode, select View→3D Editor menu option or press [Ctrl]+[3] 
from a keyboard. The 3D Editor window will appear. Through the 3D Editor 
window the tools for 3D data loading, ROI editing and 3D volumes analysis are 
available. 
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Loading 3D data 
To load 3D image data into the 3D Editor select File→Load image... 
from 3D Editor menu, press [Ctrl]+[L] from a keyboard or press Load image 
tool button. 
The Load 3D data dialog window appears to choose input file type and to select file 
or files to be loaded. 
To load several image files (all the files must be stored in a single folder), select a 
group of files by a typical Explorer's Shift+Ctrl+Mouse method, and then press 
Open button. 
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Setting proportions
The image may be presented with wrong proportions. The cause of this 
appearance is a way the image is produced by a medical scanner. Three-
dimensional volume is scanned over several parallel cross-sections. The 
distance between cross-sections is usually different from a distance between 
adjacent pixels within a cross-section. To set appropriate proportions of 
presented image, adjust these proportions with 3D load options dialog box 
(File→Image options... from 3D Editor menu) and set a voxel proportions 
appropriately. 
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Adjusting the 3D data view

The view angle can be adjusted after 
selecting Turn all tool. 

•   To adjust pitch or yaw angles 
press the left mouse button and 
slide the mouse cursor across the 
3D Editor window. 
•   To adjust roll angle press the 
right mouse button and move the 
mouse cursor horizontally across 
the window. 
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Adjusting the 3D data view

The viewed data can be zoomed in or 
out (or rather pulled toward or pushed 
outward) by means of Push or pull all 
tool. 

To do this select the Push or pull all 
tool and then, while pressing the left 
mouse button, move the mouse cursor 
vertically across the 3D Editor window. 



33

Adjusting the 3D data view

The data is viewed in a form of thee 
perpendicular cross-sections. Some of 
these cross-sections may be excluded 
from viewing by un-checking the X, Y 
or Z check box. 

The location of cross-section can be 
adjusted by one of three slide-bars 
located at the lower part of 3D Editor 
window. 
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Adjusting the 3D data view
The gray-scale window limits on the brightness scale 
can be adjusted by setting the position of two slide-
bars located vertically on the RHS of the window. 
These adjustment tools are useful for correcting the 
image contrast or overall brightness of presented 
data. 

Below the slide-bars there are three radio buttons. 
Choosing the middle one will cause the image to be 
displayed in three gray-levels. The slide-bars in this 
mode serve as gray-level threshold selectors. 
Choosing the lower radio button will cause the data to 
disappear. The viewed cross-sections are uniformly 
gray (if no ROI is defined). These two modes of image 
presentation are useful when editing regions of 
interest with a Flood fill tool. 
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Editing regions of interest
To edit regions of interest for 
the textural analysis:
 
1. Select the color (number) of region 

to be created form the palette
2. Select the "drawing" mode: non-

overlapping ROI, overlapping ROI or 
modes for erasing fragments of 
already existing regions

3. Select one of predefined blocks 
(sphere, tube, cube or tetrahedron)

4. Adjust the block location, orientation, 
size and shape

5. Press Accept button to merge the 
resulting block with a ROI of selected 
color
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Editing regions of interest
To edit regions of interest for 
the textural analysis:
 
1. Select the color (number) of region 

to be created form the palette
2. Select the "drawing" mode: non-

overlapping ROI, overlapping ROI or 
modes for erasing fragments of 
already existing regions

3. Select one of predefined blocks 
(sphere, tube, cube or tetrahedron)

4-6. Adjust the block location, orientation, 
size and shape

7. Press Accept button to merge the 
resulting block with a ROI of selected 
color
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Switching regions on and off

The created regions are visible in a form of 
color highlights. 

Sometimes it is useful to temporary hide 
this highlights. The user can switch the 
ROI on and off from viewing by clicking 
tiny bars located just below color (ROI 
number) selection buttons. These tiny bars 
have also informative function. They are 
colored if the corresponding region exists 
and grayed otherwise. 
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Flood-filling the volume

The ROI may be also created by 
means of flood-filling tool. To get the 
volume flood-filled, it is convenient to 
switch the image to three gray-level 
presentation mode and set up the gray-
level scale thresholds to distinguish the 
volume to be filled-in. Next step is to 
select the Flood-fill too, point with a 
mouse cursor at the volume. 
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Elastic surface model 
An elastic surface is a mathematical 
model of enclosed surface that deforms 
upon some local characteristics of 3D 
image. The final shape of the model 
depends on initial shape, location of the 
surface and model’s parameters. In 
MaZda's 3D Editor the model of center 
point deformable surface has been 
implemented for ROI editing. 

To edit ROI with elastic surface:
1.  Select Create spherical-elastic ROI tool
2.  Adjust position and size of a model
3.   If needed, switch off automatic mode 
      and adjust Thresh. and Deform.
      parameters 
4.   Press the Accept button 
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Moving and copying regions 
Any existing region can be moved or copied. To move or copy the region: 
1. Select, from a palette toolbox, a color (number) of a region to be moved or copied.
2. Select a Move or Copy button 

(after a while a three-dimensional model of selected region will appear)
3. Change the location of the region by means of move, push or pull tools and a mouse. 
4. Press the Accept button
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Editing 3D ROI in 2D
The region of interest can be edited cross-section by cross-section. To edit a 
selected Zth cross-section, just switch to the main MaZda window, edit ROI 
by means of 2D editing tools and switch back to 3D Editor window. The 
selected cross-section will be updated. 
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Analysis of 3D data 
MaZda computes textural features within selected 3D regions of interest. To 
select options of the computation process select Analysis→Options... from 
the 3D Editor menu. 
The image can be analyzed as is or may be normalized before textural features computation. 
There are two types of 3D image analysis implemented in the current version of MaZda, based on 
image histogram computation and on co-occurrence matrix. 

Analysis of the 3D data within the defined regions of interest starts after selecting 
the Analysis→Run 3D analysis... from the 3D Editor menu. The results of the 
analysis are presented in the Report window. 
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Exercise 1

1. Start MaZda and switch it to a 3D Editor

2. Load MRI cross-sections of a head (BR0000.BMP - BR0063.BMP)
from Tutorials\4_3D_Analysis folder

3. Define regions covering eye bolls with 
Create elypsoidal ROI tool

4. Define region covering a cerebrum with elastic surface tool 
(if needed use the elastic surface model several times 
to fill in a whole volume of cerebrum)

5. Set analysis options of your choice

6. Start the analysis of 3D data

7. What is a volume of cerebrum in voxels?
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Exercise 2

1. Start MaZda or, if it is already started, close all the report 
tab-pages 

2. Switch it to a 3D Editor
3. Load tex3d1.bmf file
4. Define 16 cubic regions of interest of an approximate size 

30x30x30 voxels 
(the regions may overlap)

5. Set analysis options and run the 3D analysis
6. Set class names of feature vectors to Texture1
7. Load tex3d2.bmf file and run the 3D analysis
8. Set class names of just generated feature vectors to Texture2
9. Select the most discriminative features and reduce feature 

vector size with methods implemented in MaZda and B11
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Plugins

Plugins are implemented in MaZda 
through its macro technology. 
Macro files given a “.plugin” 
extension, located in MaZda’s 
working directory are recognized as 
plugins, and are accessible from 
the MaZda Tools menu.
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MaZda macro instructions
LoadImage file_path_and_name – loads an image for analysis from a given file, 
LoadROI file_path_and_name – loads regions of interest from a given file, 
LoadOptions file_path_and_name – loads options from a given file, 
LoadReport file_path_and_name – loads a report into the report window, 
ColorChannel [arg = Y, R, G, B, U, V, H or S] – selection of color conversion mode, 
ReloadImage – reloading an opened image (e.g. after changeing a color conversion mode), 
RunAnalysis – starts the analysis process, 
Execute file_path_and_name argument_list – executes program from a given file, 
AggregateReports – joins data from two reports, 
SaveImage – saves an opened image, 
SaveSelected file_path_and_name – saves selected features to a given file, 
SaveReport file_path_and_name – saves report from opened tab-page of report window to a given file, 
SaveMap file_path_and_name – saves feature map from opened tab-page to a given file, 
CloseReport – closes opened tab-page of report window, 
CloseMap – closes opened tab-page of feature map, 
Exit – unconditional MaZda termination. 

Any line starting with ‘/ ’ or ‘;’ is a comment, which is ignored by the interpreter
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Exercise 1
1. With a notepad editor open a file Report2notepad.plugin located 

in MaZda folder 
2. What is a purpose of this plugin?
3. Start MaZda and load any report to the Report window
4. Now, run the Report2notepad plugin (Tools→Report2notepad)

5. Write a plugin that will save currently opened image into a 
temp.bmp file and then will open it with mspaint.exe program
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Maps computation
MaZda allows also for maps computation, 

which are texture parameters computed in 
a small window sliding over the image 
surface. The maps computation is basically 
a form of image nonlinear filtration.

To compute maps:
1. Open Options dialog box 

(Analysis→Options) and select Maps tab-
page

2. Indicate an element in the tree diagram and 
then click a "select" or "clear" button to, 
respectively, select or unselect features for 
maps generation

3. Run the image analysis (Analysis→Run)
4. When the analysis completes the Image 

view window appears and the resulting 
maps are presented
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Maps computation
MaZda allows also for maps computation, 

which are texture parameters computed in 
a small window sliding over the image 
surface. The maps computation is basically 
a form of image nonlinear filtration.

To compute maps:
1. Open Options dialog box 

(Analysis→Options) and select Maps tab-
page

2. Indicate an element in the tree diagram and 
then click a "select" or "clear" button to, 
respectively, select or unselect features for 
maps generation

3. Run the image analysis (Analysis→Run)
4. When the analysis completes the Image 

view window appears and the resulting 
maps are presented
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Exercise 1
• Start MaZda 

• Load image mazdatex.bmp from Tutorials\6_Feature_maps folder

• What does this image present?

• Set analysis options for computation of histogram maps, set 
normalization to image. 

• Run the analysis

• The Image view window will apeare

• Switch the image view tab-page to Perc.10% map

• What does this image present?
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